Crypto

A critical security vulnerability has been identified in Ethereum


Blockchain-based Security Startup Peckshield encountered a critical security vulnerability in the Ethereum smart contracts (based on the ERC20 protocol).

This vulnerability is caused when computers are dealing with numeric values ​​outside the range that can be represented by a certain number of bits,

Researchers have indicated that the error in their work is in tokens such as UGToken, SMART, MTC, FirstCoin, GG Token, CNY Token, and SMT tokens.

According to the researchers, this error is due to the large amount it makes it possible to transfer an adrese with a zero value.

PeckShield emphasizes that comprehensive control of smart contracts is crucial, although Ethereum has traditional mechanisms to protect against such situations.

The company is concerned that these weaknesses

In addition, the company emphasized the importance of comprehensive oversight of intelligent contracts before distribution.

Poloniex, HitBTC, OKex and Huobi Pro such as crypto money exchanges, ERC20 token traders took the suspension.

Researchers say that some affected tokens (such as gate.io, HitBTC, YoBit, and CoinExchange) may still be able to trade on some stock exchange.

This is the first error that researchers have found in ethereum-based smart contracts not.

Actually, a month ago, Coinbase suffered from a similar question that allowed users to reward themselves with infinite amounts of practical Ethereum